Atlas Seattle Slowness Tuesday 20th January 2026 17:28:07


We have received reports that customers are facing packet loss and slow network speeds in our Seattle Datacenter. After investigation it has been linked to an upstream network carrier that is facing issues. They have not yet provided an ETA on resolution but as soon as we have updates we will be posting them here.

Update 1/20/2026 at 12:14pm EST: The datacenter NOC team has identified the issue with a network backbone splice and is currently working to restore service. Additional damage was found, and repairs are ongoing. At this time, there is no estimated time for full restoration.

Update 1/21/2026 at 10:20am EST: The upstream carrier reports that the replacement 288-count fiber cable has been successfully pulled into place and both ends of the cable have been fully prepared. Splice work is being performed.

Update 1/21/2026 at 2:48pm EST: The upstream carrier has confirmed the fiber cable has been repaired

Update 1/20/2026 at 10:37pm EST: The new fiber has been installed, and crews on site are now working on splicing the connections. At this time, there is still no confirmed estimated time of restoration (ETR).

Update 1/20/2026 at 1:12am EST: The upstream providers optical team is currently working on new cable placement for the additional damage found. Once both ends are prepared an ETR will be provided.

Update 1/20/2026 at 3:37pm EST: We want to provide a clear summary update regarding the service degradation affecting the Seattle datacenter location.

The issue has been traced to damage on an upstream fiber network that provides connectivity into the Seattle datacenter area. While this infrastructure is outside of the building and outside of owned network, it directly impacts service performance for customers connected through this path.

Once the issue was identified, repair efforts began immediately. During the initial repair work, additional damage was discovered, which expanded the scope of the restoration and extended the overall timeline. Crews have been working through the night and remain actively on site. As of the latest update, crews are pulling new fiber as part of the repair process.

At this time, there is no confirmed estimated time of restoration (ETR), as work is still ongoing. As soon as a reliable update on timing becomes available, we will share it here promptly.

We understand how disruptive this has been and appreciate your patience. ISP is closely monitoring the situation and coordinating updates as work progresses, and we will continue to communicate until service is fully restored.